Configuration

Un article de Mobidyc.

configuration minimale

Toute machine ayant au moins 64 Mo de mémoire et un écran VGA standard (640x480) peut faire tourner Mobidyc, mais il est recommandé de disposer d'au moins 100 Mo de mémoire, d'une bonne carte graphique et du processeur le plus rapide du moment.

Mobidyc est écrit en SmallTalk et utilise l'environnement de programmation Visual Works de Cincom. Cet environnement fonctionne sur plates-formes Macintosh (OS 9 et X), Windows (98, NT, 2K, XP), et de nombreuses stations Unix (Sun Solaris, Linux(s), HP-UX). Nous avons testé Mobidyc sous Mac OS 9, Mac OS 10.x, Windows 98, 2000, NT, XP SP1 & SP2, Sun/Solaris et Linux Mandrake (8.x, 9.x, 10.x), Red Hat (7.3), Debian (noyau 2.6.x). De légères différences de tailles de polices peuvent apparaîtrent d'une plate-forme à l'autre.

module principal

Cincom VisualWorks est gratuit pour des utilisations scientifiques ou éducatives non commerciales et doit être chargé sur votre machine avant d'utiliser Mobidyc. La dernière version de cet environnement est la 7.3.1. Pour une utilisation normale, le moteur VisualWorks est distribué avec l'archive Mobidyc que vous pouvez télécharger sur ce site. Pour une utilisation en temps que développeur Smalltalk il faut charger l'environnement VisualWorks complet. Cela se fait en plusieurs temps :


Mobidyc a été développé avec des versions VW inférieures ou égales à la 7.3.1, 
il a été testé avec le version VW 7.4, mais pas au-dela.


De même Mobidyc fonctionne parfaitement sous Windows XP SP1, SP2, Mac Tiger et Linux  
(quelque soit la distribution)
Windows Vista, Windows XP SP3, Mac Leopard n'ont pas été testés.

éditeur mathématique

Le nouveau module d'édition d'équations mathèmatiques à été développé en Java. Il repose sur des bibliothèques MathML. Son utilisation nécessite l'installation d'une machine virtuelle java. Cela peut se faire de deux manière, soit installer simplement la marchine virtuelle pour faire tourner les applications java (c'est la distribution Java Runtime Environment), soit installer un package qui permet en plus de recompiler des programmes Java (on parle de Java 2 plateform Standart Edition). Dans les 2 cas il faut une version supérieure ou égale à 1.4.2.